import re
regex = re.compile(r"^PAT_A_[^;\n]*(?:\n(?![^\n;]*NOT_MATCH_THIS)[^;\n]*)*\n[^;\n]*PAT_B.*(?:[^;]*);", flags=re.MULTILINE)
test_str = ("PAT_A_YYY(\n"
" OK,\n"
" PAT_B\n"
");\n\n"
"PAT_A_XXX(\n"
" NOT_MATCH_THIS,\n"
" PAT_B\n"
");")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")