#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d{2}N)[\S\s]*?(?=NONREF)"
Local $sString = "221222DY1356,63NCCPNONREF" & @CRLF & _
"221222DY1356,63NTRFNONREF" & @CRLF & _
"221222DY1356,63NEFTNONREF" & @CRLF & _
"221222DY1356,63NMSCNONREF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")