using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d{2}N)[\S\s]*?(?=NONREF)";
string input = @"221222DY1356,63NCCPNONREF
221222DY1356,63NTRFNONREF
221222DY1356,63NEFTNONREF
221222DY1356,63NMSCNONREF";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}