const regex = /(?<=\d{2}N)[\S\s]*?(?=NONREF)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{2}N)[\\S\\s]*?(?=NONREF)', 'gm')
const str = `221222DY1356,63NCCPNONREF
221222DY1356,63NTRFNONREF
221222DY1356,63NEFTNONREF
221222DY1356,63NMSCNONREF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}