use strict;
my $str = '221222DY1356,63NCCPNONREF
221222DY1356,63NTRFNONREF
221222DY1356,63NEFTNONREF
221222DY1356,63NMSCNONREF';
my $regex = qr/(?<=\d{2}N)[\S\s]*?(?=NONREF)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}