import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{2}N)[\\S\\s]*?(?=NONREF)";
final String string = "221222DY1356,63NCCPNONREF\n"
+ "221222DY1356,63NTRFNONREF\n"
+ "221222DY1356,63NEFTNONREF\n"
+ "221222DY1356,63NMSCNONREF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}