$re = '/(?<=\d{2}N)[\S\s]*?(?=NONREF)/m';
$str = '221222DY1356,63NCCPNONREF
221222DY1356,63NTRFNONREF
221222DY1356,63NEFTNONREF
221222DY1356,63NMSCNONREF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);