using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*[^\W_\n]+_[a-z]\d+\b|(\d)";
string input = @"*specially_x00123 hello23 the2e are 13 5.12apples named 31st";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}