package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\*[^\W_\n]+_[a-z]\d+\b|(\d)`)
var str = `*specially_x00123 hello23 the2e are 13 5.12apples named 31st`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}