re = /\*[^\W_\n]+_[a-z]\d+\b|(\d)/m
str = '*specially_x00123 hello23 the2e are 13 5.12apples named 31st'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end