const regex = new RegExp('\\*[^\\W_\\n]+_[a-z]\\d+\\b|(\\d)', 'gm')
const str = `*specially_x00123 hello23 the2e are 13 5.12apples named 31st`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}