import re
regex = re.compile(r"\*[^\W_\n]+_[a-z]\d+\b|(\d)", flags=re.MULTILINE)
test_str = "*specially_x00123 hello23 the2e are 13 5.12apples named 31st"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")