// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\*[^\W_\n]+_[a-z]\d+\b|(\d)").unwrap();
let string = "*specially_x00123 hello23 the2e are 13 5.12apples named 31st";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}