#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[6789]\d{8}$"
Local $sString = "630222544" & @CRLF & _
"941641893" & @CRLF & _
"625233988" & @CRLF & _
"724903785" & @CRLF & _
"816794701" & @CRLF & _
"" & @CRLF & _
"910 50 78 87" & @CRLF & _
"928-93-38-79" & @CRLF & _
" 628238339" & @CRLF & _
"275766639" & @CRLF & _
"+34 969 97 22 01" & @CRLF & _
"792199000 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")