$re = '/^[6789]\d{8}$/m';
$str = '630222544
941641893
625233988
724903785
816794701
910 50 78 87
928-93-38-79
628238339
275766639
+34 969 97 22 01
792199000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);