# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/+$|(\/){2,}/\1/gm;t' <<< "test1/test2/test3/test4/test5/
test1/test2/test3/test4//
test1/test2/test3///
test1/test2////
test1/////"