use strict;
my $str = 'test1/test2/test3/test4/test5/
test1/test2/test3/test4//
test1/test2/test3///
test1/test2////
test1/////';
my $regex = qr~/+$|(/){2,}~mp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";