package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/+$|(/){2,}`)
var str = `test1/test2/test3/test4/test5/
test1/test2/test3/test4//
test1/test2/test3///
test1/test2////
test1/////`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}