using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/+$|(/){2,}";
string substitution = @"\1";
string input = @"test1/test2/test3/test4/test5/
test1/test2/test3/test4//
test1/test2/test3///
test1/test2////
test1/////";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}