$re = '~/+$|(/){2,}~m';
$str = 'test1/test2/test3/test4/test5/
test1/test2/test3/test4//
test1/test2/test3///
test1/test2////
test1/////';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;