#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/+$|(/){2,}"
Local $sString = "test1/test2/test3/test4/test5/" & @CRLF & _
"test1/test2/test3/test4//" & @CRLF & _
"test1/test2/test3///" & @CRLF & _
"test1/test2////" & @CRLF & _
"test1/////"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)