#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/news/[^?/\n]+/?"
Local $sString = "Доброго времени суток." & @CRLF & _
"Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:" & @CRLF & _
"0 для /news/" & @CRLF & _
"0 для /news/?test=1&dsds" & @CRLF & _
"1 для /news/название статьи/" & @CRLF & _
"1 для /news/название статьи" & @CRLF & _
"1 для /news/название статьи/?test=1&dsds" & @CRLF & _
"0 для всего остального" & @CRLF & _
"" & @CRLF & _
"И что почитать/посмотреть про регулярки? (вики и MDN не помогают)" & @CRLF & _
"" & @CRLF & _
"Спасибо!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")