use strict;
my $str = 'Доброго времени суток.
Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:
0 для /news/
0 для /news/?test=1&dsds
1 для /news/название статьи/
1 для /news/название статьи
1 для /news/название статьи/?test=1&dsds
0 для всего остального
И что почитать/посмотреть про регулярки? (вики и MDN не помогают)
Спасибо!';
my $regex = qr@/news/[^?/\n]+/?@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}