import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/news/[^?/\\n]+/?";
final String string = "Доброго времени суток.\n"
+ "Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:\n"
+ "0 для /news/\n"
+ "0 для /news/?test=1&dsds\n"
+ "1 для /news/название статьи/\n"
+ "1 для /news/название статьи\n"
+ "1 для /news/название статьи/?test=1&dsds\n"
+ "0 для всего остального\n\n"
+ "И что почитать/посмотреть про регулярки? (вики и MDN не помогают)\n\n"
+ "Спасибо!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}