$re = '@/news/[^?/\n]+/?@m';
$str = 'Доброго времени суток.
Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:
0 для /news/
0 для /news/?test=1&dsds
1 для /news/название статьи/
1 для /news/название статьи
1 для /news/название статьи/?test=1&dsds
0 для всего остального
И что почитать/посмотреть про регулярки? (вики и MDN не помогают)
Спасибо!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);