using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/news/[^?/\n]+/?";
string input = @"Доброго времени суток.
Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:
0 для /news/
0 для /news/?test=1&dsds
1 для /news/название статьи/
1 для /news/название статьи
1 для /news/название статьи/?test=1&dsds
0 для всего остального
И что почитать/посмотреть про регулярки? (вики и MDN не помогают)
Спасибо!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}