import Foundation
let pattern = #"/news/[^?/\n]+/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Доброго времени суток.
Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:
0 для /news/
0 для /news/?test=1&dsds
1 для /news/название статьи/
1 для /news/название статьи
1 для /news/название статьи/?test=1&dsds
0 для всего остального
И что почитать/посмотреть про регулярки? (вики и MDN не помогают)
Спасибо!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)