import re
regex = re.compile(r"/news/[^?/\n]+/?", flags=re.MULTILINE)
test_str = ("Доброго времени суток.\n"
"Подскажите, пожалуйста, как написать регулярку чтобы preg_match выдал:\n"
"0 для /news/\n"
"0 для /news/?test=1&dsds\n"
"1 для /news/название статьи/\n"
"1 для /news/название статьи\n"
"1 для /news/название статьи/?test=1&dsds\n"
"0 для всего остального\n\n"
"И что почитать/посмотреть про регулярки? (вики и MDN не помогают)\n\n"
"Спасибо!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")