#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-zA-Z]{2,}\d*|[a-zA-Z]\d{2,})$"
Local $sString = "BadUs3rnam3" & @CRLF & _
"c57bT3" & @CRLF & _
"aa" & @CRLF & _
"aa" & @CRLF & _
"a111111" & @CRLF & _
"a1" & @CRLF & _
"11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")