re = /^(?:[a-zA-Z]{2,}\d*|[a-zA-Z]\d{2,})$/m
str = 'BadUs3rnam3
c57bT3
aa
aa
a111111
a1
11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end