const regex = /^(?:[a-zA-Z]{2,}\d*|[a-zA-Z]\d{2,})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-zA-Z]{2,}\\d*|[a-zA-Z]\\d{2,})$', 'gm')
const str = `BadUs3rnam3
c57bT3
aa
aa
a111111
a1
11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}