import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z]{2,}\\d*|[a-zA-Z]\\d{2,})$";
final String string = "BadUs3rnam3\n"
+ "c57bT3\n"
+ "aa\n"
+ "aa\n"
+ "a111111\n"
+ "a1\n"
+ "11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}