$re = '/^(?:[a-zA-Z]{2,}\d*|[a-zA-Z]\d{2,})$/m';
$str = 'BadUs3rnam3
c57bT3
aa
aa
a111111
a1
11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);