using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CRLF\n(?!Conduit)";
string input = @"Conduit 1 CRLF
10 CRLF
23 CRLF
Conduit 1 CRLF
22 CRLF
12 CRLF
Conduit 2 CRLF";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}