import Foundation
let pattern = #"CRLF\n(?!Conduit)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Conduit 1 CRLF
10 CRLF
23 CRLF
Conduit 1 CRLF
22 CRLF
12 CRLF
Conduit 2 CRLF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)