import re
regex = re.compile(r"CRLF\n(?!Conduit)")
test_str = ("Conduit 1 CRLF\n"
"10 CRLF\n"
"23 CRLF\n"
"Conduit 1 CRLF\n"
"22 CRLF\n"
"12 CRLF\n"
"Conduit 2 CRLF")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")