const regex = /CRLF\n(?!Conduit)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CRLF\\n(?!Conduit)', 'g')
const str = `Conduit 1 CRLF
10 CRLF
23 CRLF
Conduit 1 CRLF
22 CRLF
12 CRLF
Conduit 2 CRLF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}