re = /CRLF\n(?!Conduit)/
str = 'Conduit 1 CRLF
10 CRLF
23 CRLF
Conduit 1 CRLF
22 CRLF
12 CRLF
Conduit 2 CRLF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end