#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\@][A-Za-z0-9_]{1,15}$"
Local $sString = "@ryanmaclean365" & @CRLF & _
"@really_ryan" & @CRLF & _
"@really-ryan" & @CRLF & _
"@1234567890123456" & @CRLF & _
"@123456789012345" & @CRLF & _
"really ryan" & @CRLF & _
"@really ryan" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")