using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\@][A-Za-z0-9_]{1,15}$";
string input = @"@ryanmaclean365
@really_ryan
@really-ryan
@1234567890123456
@123456789012345
really ryan
@really ryan
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}