$re = '/[\@][A-Za-z0-9_]{1,15}$/m';
$str = '@ryanmaclean365
@really_ryan
@really-ryan
@1234567890123456
@123456789012345
really ryan
@really ryan
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);