package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\@][A-Za-z0-9_]{1,15}$`)
var str = `@ryanmaclean365
@really_ryan
@really-ryan
@1234567890123456
@123456789012345
really ryan
@really ryan
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}