const regex = /[\@][A-Za-z0-9_]{1,15}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\@][A-Za-z0-9_]{1,15}$', 'gm')
const str = `@ryanmaclean365
@really_ryan
@really-ryan
@1234567890123456
@123456789012345
really ryan
@really ryan
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}