use strict;
my $str = '@ryanmaclean365
@really_ryan
@really-ryan
@1234567890123456
@123456789012345
really ryan
@really ryan
';
my $regex = qr/[\@][A-Za-z0-9_]{1,15}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}