using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^""{,]+)\s*:\s*""([^""]*)"",?";
string input = @"{type:""2"",PvNum:"",Price:""1989"",UploadSec:"",UploadTime:"",RemainNum:""123"",SoldNum:""77"",MaxBuyNum:""1"", StockAttr:""颜色:留言颜色和快递"", StockString:""0#颜色:留言颜色和快递~,19.890000,123,;""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}