import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\"\\{,]+)\\s*:\\s*\"([^\"]*)\",?";
final String string = "{type:\"2\",PvNum:\"\",Price:\"1989\",UploadSec:\"\",UploadTime:\"\",RemainNum:\"123\",SoldNum:\"77\",MaxBuyNum:\"1\", StockAttr:\"颜色:留言颜色和快递\", StockString:\"0#颜色:留言颜色和快递~,19.890000,123,;\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}