const regex = /([^"{,]+)\s*:\s*"([^"]*)",?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^"{,]+)\\s*:\\s*"([^"]*)",?', 'g')
const str = `{type:"2",PvNum:"",Price:"1989",UploadSec:"",UploadTime:"",RemainNum:"123",SoldNum:"77",MaxBuyNum:"1", StockAttr:"颜色:留言颜色和快递", StockString:"0#颜色:留言颜色和快递~,19.890000,123,;"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}