// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"([^"{,]+)\s*:\s*"([^"]*)",?"#).unwrap();
let string = "{type:\"2\",PvNum:\"\",Price:\"1989\",UploadSec:\"\",UploadTime:\"\",RemainNum:\"123\",SoldNum:\"77\",MaxBuyNum:\"1\", StockAttr:\"颜色:留言颜色和快递\", StockString:\"0#颜色:留言颜色和快递~,19.890000,123,;\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}