use strict;
my $str = '{type:"2",PvNum:"",Price:"1989",UploadSec:"",UploadTime:"",RemainNum:"123",SoldNum:"77",MaxBuyNum:"1", StockAttr:"颜色:留言颜色和快递", StockString:"0#颜色:留言颜色和快递~,19.890000,123,;"}';
my $regex = qr/([^"{,]+)\s*:\s*"([^"]*)",?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}