import Foundation
let pattern = #"([^"{,]+)\s*:\s*"([^"]*)",?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"{type:"2",PvNum:"",Price:"1989",UploadSec:"",UploadTime:"",RemainNum:"123",SoldNum:"77",MaxBuyNum:"1", StockAttr:"颜色:留言颜色和快递", StockString:"0#颜色:留言颜色和快递~,19.890000,123,;"}"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)